CVE-2019-1579: Critical Pre-Authentication Vulnerability in Palo Alto Networks GlobalProtect SSL VPN Disclosed

Satnam Narang

Researchers disclose a critical vulnerability in Palo Alto GlobalProtect SSL VPN solution used by many organizations.


On July 17, researchers Orange Tsai and Meh Chang published a blog about their discovery of a pre-authentication remote code execution (RCE) vulnerability in the Palo Alto Networks (PAN) GlobalProtect Secure Socket Layer (SSL) virtual private network (VPN) used by many organizations around the world.


CVE-2019-1579 is a format string vulnerability in the PAN SSL Gateway, which handles client/server SSL handshakes. More specifically, the vulnerability exists because the gateway passes the value of a particular parameter to snprintf in an unsanitized, and exploitable, fashion. An unauthenticated attacker could exploit the vulnerability by sending a specially crafted request to a vulnerable SSL VPN target in order to remotely execute code on the system.

Though the researchers reported their findings to PAN, the company responded that the vulnerability had been identified internally and fixed, hence why no CVE identifier was assigned and why newer versions of GlobalProtect are not vulnerable.

From there, the researchers sought to identify whether any large organizations might be running a vulnerable version of GlobalProtect. They found that popular ride-hailing service, Uber, was running an unpatched version. They confirmed their exploit worked against Uber and reported their findings. Uber responded it did not use PAN SSL VPN as its “primary VPN” and that it was hosted on Amazon Web Services (AWS) and not a part of the organization’s “core infrastructure,” which mitigated some of the potential impact of this vulnerability.

We expect to see more incoming scans to identify organizations running vulnerable instances of the PAN SSL VPN in their environments.

Proof of concept

Tsai and Chang included a proof-of-concept (PoC) in their blog post, but it requires modification in order to work successfully. They also provided a command to help identify vulnerable GlobalProtect versions based on the login.css file (8.x) and a .gif file (7.x).

Vendor response

Since publication of Tsai and Chang’s blog, PAN has assigned a CVE identifier, CVE-2019-1579, and published a security advisory, PAN-SA-2019-0020, for it.


The following table contains information about vulnerable versions and fixed or non-vulnerable versions of the PAN-OS:

Affected version Fixed version PAN-OS 7.1.18 and earlier PAN-OS 7.1.19 and later PAN-OS 8.0.11 and earlier PAN-OS 8.0.12 and later PAN-OS 8.1.2 and earlier PAN-OS 8.1.3 and later

This vulnerability does not impact PAN-OS 9.0.

Additionally, PAN-SA-2019-0020 provides mitigations for customers who cannot upgrade to a patched version. The company recommends updating to “content release 8173, or a later version” as well as ensuring threat prevention is “enabled and enforced on traffic that passes through the GlobalProtect portal and GlobalProtect Gateway interface.”

Identifying affected systems

A list of Nessus plugins to identify this vulnerability will appear here as they’re released.

Get more information

Join Tenable's Security Response Team on the Tenable Community.

Learn more about Tenable, the first Cyber Exposure platform for holistic management of your modern attack surface.

Get a free 60-day trial of

Read more >

Published on Jul 19, 2019

We have big plans for continued global growth, and we’re looking for people who are creative, flexible and dedicated to helping us build something great – something that matters.