CVE-2019-0708: BlueKeep Exploits Could Be Around the Corner

Scott Caveza

Nearly 80 days after the announcement of BlueKeep, threats of exploitation remain. Those who have not patched remain at risk as rumors of exploit scripts surface.

Background

In May 2019, Microsoft released a critical patch for CVE-2019-0708, dubbed BlueKeep, a critical remote code execution vulnerability that could allow an unauthenticated attacker to exploit a vulnerable host running Remote Desktop Protocol (RDP). Microsoft took the unusual step of publishing a blog post announcing security updates for out-of-support versions of Windows, including Windows XP and Windows 2003, and warning that BlueKeep could be as impactful as the WannaCry worm that took hold in May 2017. Despite the criticality of the issue, reports suggest that over 800,000 machines remain vulnerable. The number of unpatched machines is concerning considering exploits have been developed and proof of concept code (PoC) continues to appear on popular sites like GitHub.

Analysis

As we outlined in our May blog, BlueKeep is a pre-authentication vulnerability that requires no user interaction and allows arbitrary code to be run on a vulnerable remote target. Less than 24 hours after Microsoft’s disclosure on Patch Tuesday, Microsoft Security Response Center (MSRC) warned of the potential for BlueKeep to be widely exploited and wormed. Several projects began to pop up on sites like GitHub with fake exploits and malicious code. Since May, that number continues to increase and there are many claims of working examples.

Our own Tenable Researchers worked tirelessly following Patch Tuesday to develop plugins to identify vulnerable assets both through unauthenticated remote checks, and authenticated local checks. Our authenticated local plugins were released within hours of Microsoft’s disclosure, while an unauthenticated remote plugin was released just a week after the BlueKeep disclosure.

In the weeks since BlueKeep was announced, coverage and interest in exploitation continue to increase. For example, security vendor Immunity has announced an exploit module, and independent researcher zerosum0x0 has developed an exploit which may soon be found in open source tools. In addition, a new variant of the WatchBog malware now includes a scanning module for BlueKeep. The vulnerability has gained so much attention that US-CERT released an alert urging users and administrators to take action immediately.

Solution

Tenable recommends applying the appropriate patches immediately. Microsoft has provided updates for Windows 7, Windows Server 2008 and Windows Server 2008 R2. Additionally, Microsoft has provided patches for out-of-support systems, including Windows XP and Windows Server 2003.

Tenable also recommends the following mitigation steps:

  • Enabling Network Level Authentication (NLA). Microsoft recommends NLA as a mitigation, however NLA may be something an organization chooses to deploy in addition to patching.
  • Blocking RDP (Default is TCP port 3389) at your perimeter firewall.
  • Disabling any unused services.
  • Upgrading end-of-life (EOL) operating systems.

Identifying affected systems

Tenable’s remote plugin for CVE-2019-0708 can be found here. This plugin can be used to identify affected systems without providing credentials.

For identifying systems without NLA enabled, please use plugin 58453.

A list of all plugins to identify BlueKeep (CVE-2019-0708) is available here.

Get more information

Join Tenable's Security Response Team on the Tenable Community.

Learn more about Tenable, the first Cyber Exposure platform for holistic management of your modern attack surface.

Get a free 60-day trial of Tenable.io.

Read more >

Published on Aug 1, 2019

We have big plans for continued global growth, and we’re looking for people who are creative, flexible and dedicated to helping us build something great – something that matters.